Quickbooks Web Connector - Certificate Revoked Error
Incident Report for gotomyerp
Resolved
Good news! Microsoft/Symantec/DigiCert seem to have rectified the Certificate/Server situation that led to the "Certificate Revoked" message. We've recently confirmed that the AvaTax Desktop connector is now operating correctly on our test servers without any modifications. We're optimistic that this resolution applies to other applications impacted by this certificate concern.

Kindly assess your integrations tomorrow morning, especially if you encountered issues today. Should you require further help, please get in touch with our support team: support@gotomyerp.com
Posted Aug 24, 2023 - 21:11 PDT
Monitoring
The QB Web Connector update that Intuit provided is proving successful with all customers using it for a third-party integration.

We continue to work with customers using third-party integration and the respective publishers to put in place the necessary updates to get the new certificates properly set up.

If you are using a third-party integration and are still receiving the error, please get in touch with support@gotomyerp.com so that our team can advise and assist.

Currently, customers running Avalara with Quickbooks are still experiencing integration issues.
The Avalara team is working on a solution as high-priority, and we look forward to sharing that with you as soon as they release an updated version of their connector.

Meanwhile, our team is testing a workaround that is proving successful in restoring Avalara connectivity using the latest version of the Avalara connector. We will keep those Avalara customers updated with our progress to get them back up and running as soon as possible

We sincerely thank you again for your patience as we navigate through this widespread issue, and apologize for the inconvenience it may be causing.
Posted Aug 24, 2023 - 09:52 PDT
Update
Intuit is aware of this issue and is working with third-party publishers for a resolution. Some third-party applications with Symantec certificates are still showing as revoked.

At this time, integrated products using the Quickbooks Web Connector should be functional again. Please see the following article for information on re-accepting the certificate if and when necessary:
https://support.gotomyerp.com/portal/en/kb/articles/manage-quickbooks-qwc-and-third-party-integrations

For third-party publishers: If your organization is experiencing the "Certificate Revoked Error":
Please get in touch with the publisher of the software in question and get confirmation whether the latest release has a working certificate.
- If yes, please let us contact support@gotomyerp.com and request an update to the latest version.
- If no, please stay in touch with the respective publisher until they issue a new version that has the updated certificate.

Please note that aside from the above 2 possible solutions, gotomyerp cannot do anything further as a workaround until the publishers have issued an updated version of their software.

We will continue updating the status of this incident as more information is made available.

We appreciate your patience during this process and thank you for your understanding.
Posted Aug 23, 2023 - 13:29 PDT
Identified
Intuit has yet to identify the root cause of the REVOKED SSL Certificate for 3rd Party Applications. Intuit has escalated to priority 1 status with several providers, including DigiCert and Microsoft. This matter is not exclusive to the gotomyerp platform but impacts all desktop software publishers and 3rd Party vendors that integrate with QuickBooks Desktop.

For applications using the Quickbooks Web Connector (QWC), such as TSheets (now known as Quickbooks Time), Intuit has released an initial patch already deployed to your server. Users only need to re-accept the application certificate during synchronization. For guidance on reintegration or certificate re-acceptance, please refer to the following article: https://support.gotomyerp.com/portal/en/kb/articles/manage-quickbooks-qwc-and-third-party-integrations

For applications reliant on third-party connectors, challenges persist, and investigations are underway. If you encounter issues with your integrated product, please contact support@gotomyerp.com, and we can inform you of any existing solutions or workaround, if any are known at that time.

As of this update, there is no provided estimated resolution time. However, rest assured that we will promptly relay the information to our users as we receive updates.

We deeply understand the impact on your operations and sincerely appreciate your patience as we work towards a solution with the third-party providers.

P.S.: Please hit the "Subscribe to Updates" at the top of this page to get notified of any new updates regarding this and future matters.
Posted Aug 23, 2023 - 10:12 PDT
Investigating
We are receiving reports related to a "Certificate Revoked" error when utilizing the Quickbooks Web Connector.
This occurs for all Quickbooks users and is not specific to the gotomyerp hosting platform.

We will provide further updates as they are made available.
Posted Aug 22, 2023 - 16:15 PDT
This incident affected: Application Services (Quickbooks Desktop).